Re: Segmentation Fault on DMO runs on power9

From: Volker Springel <vspringel_at_MPA-Garching.MPG.DE>
Date: Thu, 25 Feb 2021 15:57:53 +0100

Hi Tiago,

Hm, it possibly is a shared memory access problem given the place where this happens. Does the code run on a single node? Which MPI library is this? Certainly a buggy MPI-3 support is a primary suspect for this. It's also peculiar that the machine allows only 40% of the physical memory to be allocated as shared memory... (this is not good).

You can try to activate DEBUG to see whether this gives a core file for the crash. This would allow to locate the line where this happens by loading the core-file with gdb.

Another possibility would be to add the attached stack-tracing class to the compiled files for Gagdet4. This will activate a signal handler and - if you are moderately lucky - print an informative stack-trace when the crash happens.

Regards,
Volker






> On 25. Feb 2021, at 15:18, Tiago Castro <tiagobscastro_at_gmail.com> wrote:
>
> Dear list,
>
> I have tried to run g4 on a power9 cluster, and right after the IC creation and during the first step the code returns me segmentation fault. Any suggestions of what I am doing wrong?
>
> Many thanks for any help you can provide.
> Regards,
> T.
> <param.std.txt><Config.sh><slurm-2608670.out>
> -----------------------------------------------------------
>
> If you wish to unsubscribe from this mailing, send mail to
> minimalist_at_MPA-Garching.MPG.de with a subject of: unsubscribe gadget-list
> A web-archive of this mailing list is available here:
> http://www.mpa-garching.mpg.de/gadget/gadget-list



Received on 2021-02-25 15:57:54

This archive was generated by hypermail 2.3.0 : 2022-09-01 14:03:43 CEST