Re: galaxy collision demo

From: Jay Billings <jayjaybillings_at_gmail.com>
Date: Mon, 21 Sep 2009 11:26:23 -0400

Douglas,

I had compiled FFTW wrong in my case, but I don't know if this is the
problem with yours. You could probably track your problem down quickly with
a debugger or some print statements.

I could supply you with some snapshots, but I have to ask why need it? Also,
do you have the capability to read to read the snapshots? I don't mean for
the first question to sound offensive; I just need to be sure that you don't
need it for a homework problem or something.

Jay

On Mon, Sep 21, 2009 at 11:06 AM, Douglas/Lesli Summerstay <
dsummerstay_at_gmail.com> wrote:

> Jay,
> I imagine it may be, as you say, some kind of compilation error on my part.
> It is running, using up CPU, but not generating even the first snapshot in
> galaxy/ . Any idea the nature of the error you had? Or suggestions on how to
> track it down? Unfortunately I need the 3D position data, not just the
> video.
> Thanks again.
>
> Douglas
>
>
> On Mon, Sep 21, 2009 at 10:51 AM, Jay Billings <jayjaybillings_at_gmail.com>wrote:
>
>> Douglas,
>>
>> You are correct that you should see a snapshot at t=0 for the test
>> problem. Did you look in the galaxy/ directory? The snapshots are stored
>> there.
>>
>> The test problem with default settings only outputs six or seven snapshot
>> files from t=0 to t=3.0. I'm a bit concerned that it has taken "days"
>> without creating any snapshot files; that test problem runs in 15 minutes on
>> my quad core machine and in about an hour on my old P4. When I first started
>> working with Gadget2 I encountered a similar problem to yours and it turned
>> out to be a compile error.
>>
>> If you are only interested in videos, you might check out my youtube page:
>> http://www.youtube.com/jayjaybillings . These are videos of a different
>> simulation.
>>
>> Jay
>>
>> On Mon, Sep 21, 2009 at 10:39 AM, Douglas/Lesli Summerstay <
>> dsummerstay_at_gmail.com> wrote:
>>
>>> I am trying to run the galaxy collision sample and had a few questions:I
>>> am trying to run it on a single processor. How long should I expect to
>>> wait before seeing any output snapshot files? (I am using the default
>>> parameter file.) I left it running for days without seeing any snapshot
>>> files created. This seems odd because the first snapshot is supposed to be
>>> created at time 0. Any idea why no snapshot files are being
>>> created? Alternately, could anyone run this simulation and make the snapshot
>>> files available to me?
>>> Are the pictures of colliding galaxies on the Gadget site (
>>> http://www.mpa-garching.mpg.de/gadget/collision/index.html ) from this
>>> simulation?
>>>
>>> Thanks for your help.
>>>
>>> --
>>> http://dsummerstay.googlepages.com
>>>
>>>
>>> -----------------------------------------------------------
>>>
>>> If you wish to unsubscribe from this mailing, send mail to
>>> minimalist_at_MPA-Garching.MPG.de with a subject of: unsubscribe
>>> gadget-list
>>> A web-archive of this mailing list is available here:
>>> http://www.mpa-garching.mpg.de/gadget/gadget-list
>>>
>>>
>>
>>
>> -----------------------------------------------------------
>>
>> If you wish to unsubscribe from this mailing, send mail to
>> minimalist_at_MPA-Garching.MPG.de with a subject of: unsubscribe
>> gadget-list
>> A web-archive of this mailing list is available here:
>> http://www.mpa-garching.mpg.de/gadget/gadget-list
>>
>>
>
>
> --
> http://dsummerstay.googlepages.com
>
>
> -----------------------------------------------------------
>
> If you wish to unsubscribe from this mailing, send mail to
> minimalist_at_MPA-Garching.MPG.de with a subject of: unsubscribe gadget-list
> A web-archive of this mailing list is available here:
> http://www.mpa-garching.mpg.de/gadget/gadget-list
>
>
Received on 2009-09-21 17:26:25

This archive was generated by hypermail 2.3.0 : 2022-09-01 14:03:42 CEST