Re: Gsl libraries are not being found, out of ideas?

From: Ammar Ahmad Awan <ammar.ahmad.awan_at_gmail.com>
Date: Wed, 21 Jan 2009 15:58:31 +0500

Hi

I had this problem earlier. This is because of the installation of gsl. Make
a distclean with your current gsl installation and install a clean copy of
gsl with a --disable-shared switch. Make gadget again and the problem will
go away.

Cheers
-- Ammar

On Fri, Nov 21, 2008 at 5:18 PM, Ralph Rudd <theralph.rudd_at_gmail.com> wrote:

> I am trying to run Gadget2 on a e1340 cluster, Linux kernel, ssh shell
> using OpenMPI and submitting the job via Loadleveler. I am linking to a
> local installation of GSL, which works during the compile stage and the "ldd
> Gadget2" command reveals that the Gadget2 executable sees the GSL library.
> Am also exporting the LD_LIBRARY_PATH variable with the correct library path
> in my .profile and again in the Loadleveler script. However when I
> succesfully submit the job, the error output log records the following error
> about 20 times:
>
> /Gadget2: error while loading shared libraries: libgsl.so.0: cannot open
> shared object file: No such file or directory
>
> I am completely stumped. Any help would be appreciated.
> Thanks in advance
> RR
>
>
> -----------------------------------------------------------
>
> If you wish to unsubscribe from this mailing, send mail to
> minimalist_at_MPA-Garching.MPG.de with a subject of: unsubscribe gadget-list
> A web-archive of this mailing list is available here:
> http://www.mpa-garching.mpg.de/gadget/gadget-list
>
>
Received on 2009-01-21 11:58:33

This archive was generated by hypermail 2.3.0 : 2022-09-01 14:03:42 CEST