Re: Gadget compilations problems with hdf5

From: Florian Bürzle <florian.buerzle_at_uni-konstanz.de>
Date: Wed, 9 May 2012 20:37:43 +0200

Hi Andreu,

Am 09.05.2012 um 19:15 schrieb Andreu Coll i Pla:

> collect2: ld returned 1 exit status
> make: *** [Gadget2] Error 1
>

This looks like a linker error to me - are the library files really in /usr/lib64/lib or is it, for instance, just /usr/lib64?

> My makefile looks like:
>
> ifeq ($(SYSTIPE),"OWASCO")
> CC = mpicc
> OPTIMIZE = -O3 -Wall
> GSL_INCL = -I/usr/local/include
> GSL_LIBS = -L/usr/local/bin
> FFTW_INCL= -I/usr/libold/include
> FFTW_LIBS= -L/usr/libold/lib
> MPICHLIB = -I/usr/lib64/mpich2/lib
> HDF5INCL = -I/usr/lib64/include
> HDF5LIB = -L/usr/lib64/lib -lhdf5 -lz -

Did you recognize the typo? The - in the end of the last line? Is it also present in your makefile? This could also cause trouble...

> endif
> ...
> CFLAGS = $(OPTIONS) $(GSL_INCL) $(FFTW_INCL) $(HDF5INCL) -DH5_USE_16_API

By the way, you could also add the -DH5_USE_16_API into the options section of the makefile, so it will be included automatically if switched on (you won't need to hack the CFLAGS line manually then).

Cheers,
Florian
Received on 2012-05-09 20:38:46

This archive was generated by hypermail 2.3.0 : 2022-09-01 14:03:42 CEST